Failure to deliver emails to Microsoft Enterprise addresses

Incident Report for Alva Labs

Resolved

The incident has been resolved. In short, an update to Microsoft’s spam filters has caused emails from Alva to be quarantined, but this can be disabled by an IT administrator by following these instructions: https://alvalabs.notion.site/Releasing-Quarantined-emails-in-Microsoft-365-1b492fd0e1018003950af6ef5928c697
Posted Mar 13, 2025 - 12:29 UTC

Update

Instructions for how to release quaratined emails in Microsoft 365 is available at the following link: https://alvalabs.notion.site/Releasing-Quarantined-emails-in-Microsoft-365-1b492fd0e1018003950af6ef5928c697
Posted Mar 13, 2025 - 09:13 UTC

Monitoring

We are getting reports of emails not being delivered to recipients with Microsoft Enterprise addresses. We're investigating a potential fix, but in the meantime, if you are experiencing this issue, we recommend whitelisting the alvalabs.io domain or sending invitations to personal emails (e.g., gmail.com).
Posted Mar 12, 2025 - 11:24 UTC
This incident affected: Email delivery.