Loading screen on applications
Incident Report for Alva Labs
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 13:10 UTC
Investigating
We are currently investigating this issue.
Posted Apr 18, 2024 - 13:08 UTC
This incident affected: Alva App (Personality test, Logic test, Alva App).