The Alva app is not available
Incident Report for Alva Labs
Resolved
This incident has been resolved.
Posted Jun 27, 2023 - 15:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 27, 2023 - 14:59 UTC
Investigating
The app is not accessible right now. We are investigating the issue.
Posted Jun 27, 2023 - 14:59 UTC
This incident affected: Alva App (Personality test, Logic test, Alva App).