Delayed role fit score calculations

Incident Report for Alva Labs

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 14:45 UTC

Identified

We are currently experiencing some delay in the processing of role fit results. This impacts both the publishing of new scores and the recalculation of existing ones.
Posted Feb 26, 2026 - 14:21 UTC
This incident affected: Alva App (Alva App).