Issues with email delivery to Microsoft Enterprise addresses

Incident Report for Alva Labs

Resolved

We’ve isolated the issue to individual cases we’re looking into and email send out works well for everyone else.
Posted Mar 12, 2025 - 10:40 UTC

Update

We are in contact with our email provider and still investigating the issue. Preliminary findings suggest that the Microsoft Enterprise spam filtering system is contributing to the email delivery problem.
Posted Mar 12, 2025 - 06:04 UTC

Investigating

We are getting reports of emails not getting delivered to candidates with outlook clients and are investigating the issue.
Posted Mar 11, 2025 - 10:45 UTC