Delayed email sendout to some Outlook recipients

Incident Report for Alva Labs

Resolved

Deliveries to Microsoft accounts like Hotmail or Outlook are working properly. We are still keeping an eye on this.
Posted Feb 12, 2025 - 16:01 UTC

Monitoring

The situation has vastly improved, and the great majority of emails are being properly delivered. We will continue monitoring the situation.
Posted Feb 12, 2025 - 13:13 UTC

Identified

The emails to Outlook users are coming through, still at a slower rate than usual. The email provider has acknowledged the issue and is actively working on it.
Posted Feb 12, 2025 - 06:00 UTC