Delayed email sendout to Outlook recipients

Incident Report for Alva Labs

Resolved

Email deliveries to Outlook are still taking longer than expected. Our provider is working on this together with Microsoft.
Posted Feb 12, 2025 - 05:56 UTC

Update

The emails to Outlook users are coming through, still at a slower rate than usual. The email provider has acknowledged the issue and is actively working on it.
Posted Feb 11, 2025 - 18:46 UTC

Update

The emails to Outlook users are now coming through (but at a slower rate than usual).
Posted Feb 11, 2025 - 16:16 UTC

Identified

Our email provider has a delay delivering emails to Outlook users. We've let them know about the issue and are closely monitoring the situation as they are trying to address it on their end.

All other email recipients are unaffected.
Posted Feb 11, 2025 - 14:46 UTC

Investigating

We are currently investigating this issue.
Posted Feb 11, 2025 - 14:16 UTC