The send-out lag has now been resolved. All emails are sent out as expected. Please reach out to support if you still experience any issues.
Note: there are still some messages from the weekend that we haven't recovered yet. We're working with our email provider to recover and send those.
Posted Aug 12, 2024 - 07:06 UTC
Update
Overnight, we've experienced more congestion and now applied a new fix which has resumed sending.
There is still a small lag in sending, but it'll be resolved shortly.
All email communication from now on will be sent as expected and we'll also resend messages starting yesterday evening CEST.
However, not all them. Some we'll need to recover through a different procedure.
Monitoring the lag at the moment.
Stay tuned for another update shortly.
Posted Aug 12, 2024 - 06:34 UTC
Monitoring
We've handled the congestion and faster handling is expected soon. Monitoring the situation now.
Posted Aug 11, 2024 - 17:54 UTC
Update
We're continuing working to optimize the email queue.
Posted Aug 11, 2024 - 11:58 UTC
Update
The team has identified that there is a big congestion in the email queue causing the delays. We are currently working on optimizing the processing.
Posted Aug 11, 2024 - 08:56 UTC
Identified
We're currently experiencing delays in sending out emails across different user flows (i.e. candidate invitations/reminders, password recovery, inviting team members).
We've identified the issue and are in touch with our email provider to help resolve the delay.